Mishmash
Tuesday, October 24, 2017
  Ubuntu Flavors
See: https://itsfoss.com/which-ubuntu-install/
 
Monday, October 09, 2017
  Create bootable USB stick from ISO in Mac OS X

From: https://blog.tinned-software.net/create-bootable-usb-stick-from-iso-in-mac-os-x/

Booting from a USB stick is nowadays more and more important. More and more PCs (and servers) are delivered by default without a CD/DVD drive. To install the OS of your choice, USB sticks provide you the easiest possibility. In fact, it can even work out cheaper than burning a CD or DVD that you just throw away once the version is outdated.
For most Linux distributions the ISO for burning a CD/DVD is available freely on the internet. In this post I’ll assume you have already downloaded the bootable ISO image for the OS of your choice, but how to get the ISO image onto the USB stick?
The ISO file you have downloaded contains an image of the entire media. It includes all the files necessary to boot your PC/server. This image format is sadly not directly usable to copy onto the USB stick. We first need to convert the image from an ISO to a UDRW (Read/Write Universal Disk Image Format) which we can copy to the USB stick.
Some of the steps to create a bootable USB stick could be done in the GUI as well, but as some of them can’t and you have to go to the shell anyway, I decided to do all of the steps in the shell.

Convert the ISO to UDRW format

Mac OS X provides all the tools needed to convert the ISO image to UDRW. The following command will convert the ISO image to the UDRW format.
hdiutil convert -format UDRW -o destination_file.img source_file.iso
You will notice that the destination_file.img from the command will create the file destination_file.img.dmg really. This is because the hdiutil program automatically adds the dmg file extension. This is not a problem as the file extension won’t affect the format of the image.

Prepare the USB stick

Check your USB stick and make a backup if there is any important data on it, as the next steps are going to delete everything on it.
To prepare the USb stick we are going to delete all the partitions on the stick and create an empty partition. To do this we need to know the device name of the USB stick. Open a terminal and execute the following command:
$ diskutil list
You will see a list of disks and partitions. The goal is to identify the USB stick in this output. Depending on your system configuration your output might look different from this one. This appears to show 3 physical discs but it does not. The /dev/disk1 is a virtual disk created because of the partition encryption (FileVault 2) I enabled in Mac OS X.
/dev/disk0
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *500.1 GB   disk0
1:                        EFI                         209.7 MB   disk0s1
2:          Apple_CoreStorage                         399.5 GB   disk0s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
5:                 Apple_Boot Boot OS X               134.2 MB   disk0s5
/dev/disk1
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                  Apple_HFS MacOSX                 *399.2 GB   disk1
/dev/disk2
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *2.0 GB     disk2
1:       Microsoft Basic Data UNTITLED 1              2.0 GB     disk2s1
As shown in the output above, the connected USB stick is a small 2.0 GB drive with a FAT partition on it. We are now going to remove this partition in the next step. For the following steps we will need the name of the disk which in this case is “/dev/disk2”.
With the following command the data on the disk (your USB stick) will be deleted!
$ diskutil partitionDisk /dev/disk2 1 "Free Space" "unused" "100%"
With this command the USB stick was re-partitioned to have 1 partition without formatting and 100% of the size of the stick. If you check it again with “diskutil list” you will see the changes already, also the USB stick will no longer be shown in the Finder.

Copy the image to the USB stick

Now we can copy the disk image we created to the USB stick. This is done via the dd(1)command. This command will copy the image to the disk (substitute the appropriate disk name for your USB stick here, as with the re-partitioning command):
$ sudo dd if=destination_file.img.dmg of=/dev/disk2 bs=1m
if you have gnu tools installed (I have a gdd alias/symlink setup for gnu's dd)



$ sudo dd if=destination_file.img.dmg of=/dev/disk2 bs=1M status=progress

The dd command does not show any output before it has finished the copy process, so be patient and wait for it to complete.
$ diskutil eject /dev/disk2
To eject the USB stick, use the above command. After this is done, the bootable USB stick is ready to be used.
 
Tuesday, December 01, 2015
  Raspberry Pi - Disable USB Sleep Mode
Instructions here:





In case it goes away:

Disable Power Management

First you read the power management flag using :
cat /sys/module/8192cu/parameters/rtw_power_mgnt
This will report a value of “1”.
To set it to zero you can use :
sudo nano /etc/modprobe.d/8192cu.conf
and add the following line :
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
To quit from nano use [CTRL-X], [Y] then [ENTER].
You are now ready to reboot using :
sudo reboot

 
Friday, October 09, 2015
  Nike beanie
 
Monday, June 16, 2014
  On undoing, fixing, or removing commits in git
Save for later use:

On undoing, fixing, or removing commits in git
 
Thursday, July 25, 2013
  Low Carb Frappuccino (Coffee)
I've been working on a low carb coffee Frappuccino for a while. My wife and I have been on a very low carb lifestyle since the beginning of the year and I was very disappointed to find out how many carb are in the "lite" frappuccinos at Starbucks. This recipe works great for me, I have not tried any flavored variations since the plain coffee frappuccinos are my favorite.

1 cup cold coffee (I keep my leftovers in a jug in the fridge for iced coffee)
1 pack Starbuck's instant (optional) if you like a strong coffee flavor
1 cup crushed ice (as our Samsung fridge dispenses it)
1/4 cup half-n-half
1/2 teaspoon xanthan gum
4 tsp Splenda (adjust to taste)

Combine and blend. I use a "blendtec" blender on the 'smoothy' setting, it is a very powerful blender so ordinary hamilton beach (etc) blenders may not do a great job. Xanthan gum should be well known to low carbers but if you don't know about it you should find some. I've seen it in most but not all grocery stored, usually in the section that has the odd grain and baking ingredient section like spelt, corn meal, flax, etc. Last time I tried Trader Joe's they DIDN'T have it but most "health food" stores do.

 
Monday, February 18, 2013
  Connected Digital Photo Frame
Raspberry Pi +
Surplus LCD Monitor +
Open Source +
little bit of custom software =
Connected Digital Photo Frame





Features:

  • Updates automatically from 'the internet' wirelessly (via Wifi)
  • Photos can be added remotely
  • Self contained, one power cord comes out
  • Can be any size, whatever surplus LCD monitor or TV you want
Hardware Components

  • Raspberry Pi
  • Case (optional)
  • SDHC Flash Memory Card
  • Wifi adaptor
  • Powered USB Hub
  • Cables
    • Power (monitor & hub)
    • HDMI to DVI
    • USB micro (to power Pi)
    • USB mini (to hub)
Software Components

  • Client - Raspberry Pi
    • Raspbian - standard image pi linux image
    • feh (customized version, for photo display)
    • wget
    • exiftool (for reading captions)
    • custom bash scripts to automate photo downloading
  • Web Site - LAMP
    • PHP
    • exiftool (reading & writing captions)
    • jpegtran (for photo rotation) [server arch]
    • two custom php pages to manage photo
Extras - more projects to add features

  • Email photos to CDPF
  • Rotate & Crop on web site
  • Buttons on CDPF to stop, advance, reverse, delete, etc

 
Just stuff.

ARCHIVES
08/01/2003 - 09/01/2003 / 09/01/2003 - 10/01/2003 / 06/01/2005 - 07/01/2005 / 05/01/2008 - 06/01/2008 / 07/01/2008 - 08/01/2008 / 08/01/2008 - 09/01/2008 / 09/01/2008 - 10/01/2008 / 10/01/2008 - 11/01/2008 / 01/01/2009 - 02/01/2009 / 03/01/2009 - 04/01/2009 / 08/01/2009 - 09/01/2009 / 11/01/2009 - 12/01/2009 / 03/01/2011 - 04/01/2011 / 02/01/2013 - 03/01/2013 / 07/01/2013 - 08/01/2013 / 06/01/2014 - 07/01/2014 / 10/01/2015 - 11/01/2015 / 12/01/2015 - 01/01/2016 / 10/01/2017 - 11/01/2017 /


Powered by Blogger